BAB IV PENGUJIAN DAN ANALISIS - Institutional IV.pdf · PDF filePENGUJIAN DAN ANALISIS ....

Click here to load reader

  • date post

    26-Jul-2019
  • Category

    Documents

  • view

    240
  • download

    0

Embed Size (px)

Transcript of BAB IV PENGUJIAN DAN ANALISIS - Institutional IV.pdf · PDF filePENGUJIAN DAN ANALISIS ....

  • 28

    BAB IV

    PENGUJIAN DAN ANALISIS

    4.1. Pengujian Metode Dual Stack

    4.1.1. Perancangan Jaringan

    Jaringan dual stack dibuat menggunakan program GNS3 yang

    diintegrasikan dengan program virtualbox. Model jaringan dual stack yang

    dirancang seperti yang ditunjukkan pada Gambar 4.1. Perangkat yang digunakan

    terdapat dua router cisco 7200, empat VPCS, dan dua host virtualbox. Penjelasan

    interface dari masing masing perangkat sebagai berikut.

    1. R1 : Fastethernet 0/0 PC1

    2. R1 : Fastethernet 1/0 PC2

    3. R1 : Serial 2/0 R2

    4. R2 : Fastethernet 0/0 PC3

    5. R2 : Fastethernet 1/0 PC4

    6. R2 : Serial 2/0 R1

    Gambar 4.1. Jaringan Dual Stack

    4.1.2. Konfigurasi Perangkat Jaringan

    Perangkat yang terhubung pada jaringan dual stack terkonfigurasi sebagai

    berikut.

  • 29

    A. Router 1

    1. Interface fastEthernet 0/0 IPv4

    R1#enable

    R1#configure terminal

    R1(config)#interface fastEthernet 0/0

    R1(config-if)#ip address 10.10.11.1 255.255.255.0

    R1(config-if)#no shutdown

    R1(config-if)#exit

    2. Interface Serial 2/0 IPv4

    R1(config)#interface serial 2/0

    R1(config-if)#ip address 10.10.12.1 255.255.255.0

    R1(config-if)#clock rate 64000

    R1(config-if)#no shutdown

    R1(config-if)#exit

    3. Routing RIP IPv4

    R1(config)#do show ip route

    R1(config)#router rip

    R1(config-router)#network 10.10.11.0

    R1(config-router)#network 10.10.12.0

    R1(config-router)#network 10.10.13.0

    4. Interface fastEthernet 1/0 IPv6

    R1#configure terminal

    R1(config)#ipv6 unicast-routing

    R1(config)#ipv6 cef

    R1(config)#interface fastEthernet 1/0

    R1(config)#ipv6 enable

    R1(config-if)#ip address

    1000:1000:1000:1100::1/64

    R1(config-if)#no shutdown

    R1(config-if)#exit

    5. Interface Serial 2/0 IPv6

    R1(config)#interface serial 2/0

    R1(config)#ipv6 enable

    R1(config-if)#ip address

    1000:1000:1000:1200::1/64

    R1(config-if)#clock rate 64000

    R1(config-if)#no shutdown

    R1(config-if)#exit

    6. Routing RIP IPv6

    R1#do show ip route

    R1(config)#ipv6 router rip FTEK

    R1(config-rtr)#exit

    R1(config)#interface fastEthernet 1/0

    R1(config-if)#ipv6 rip FTEK enable

    R1(config-if)#exit

    R1(config)#interface serial 2/0

    R1(config-if)#ipv6 rip FTEK enable

    R1(config-if)#exit

  • 30

    B. Router 2

    1. Interface fastEthernet 0/0 IPv4

    R2#enable

    R2#configure terminal

    R2(config)#interface fastEthernet 0/0

    R2(config-if)#ip address 10.10.13.1 255.255.255.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

    2. Interface Serial 2/0 IPv4

    R2(config)#interface serial 2/0

    R2(config-if)#ip address 10.10.12.2 255.255.255.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

    3. Routing RIP IPv4

    R2(config)#do show ip route

    R2(config)#router rip

    R2(config-router)#network 10.10.11.0

    R2(config-router)#network 10.10.12.0

    R2(config-router)#network 10.10.13.0

    4. Interface fastEthernet 1/0 IPv6

    R2#configure terminal

    R2(config)#ipv6 unicast-routing

    R2(config)#ipv6 cef

    R2(config)#interface fastEthernet 1/0

    R2(config)#ipv6 enable

    R2(config-if)#ip address

    1000:1000:1000:1300::1/64

    R2(config-if)#no shutdown

    R2(config-if)#exit

    5. Interface Serial 2/0 IPv6

    R2(config)#interface serial 2/0

    R2(config)#ipv6 enable

    R2(config-if)#ip address

    1000:1000:1000:1200::2/64

    R2(config-if)#no shutdown

    R2(config-if)#exit

    6. Routing RIP IPv6

    R2#do show ip route

    R2(config)#ipv6 router rip FTEK

    R2(config-rtr)#exit

    R2(config)#interface fastEthernet 1/0

    R2(config-if)#ipv6 rip FTEK enable

    R2(config-if)#exit

    R2(config)#interface serial 2/0

    R2(config-if)#ipv6 rip FTEK enable

    R2(config-if)#exit

  • 31

    C. Komputer

    1. PC1

    IPv4 : 10.10.11.2 /24 10.10.11.1

    2. PC2

    IPv6 : 1000:1000:1000:1100::2/64

    3. PC3

    IPv4 : 10.10.13.2 /24 10.10.13.1

    4. PC4

    IPv6 : 1000:1000:1000:1300::2/64

    4.1.3. Hasil Data dan Analisa

    Metode dual stack yang dibuat mengunakan dua protokol yang berbeda,

    maka langkah uji coba digunakan dua skenario, yaitu:

    1. Dual stack IPv4, dimana pada perangkat PC1 dan PC3 akan diganti

    dengan host virtualbox, yaitu Komputer 1 dan Komputer 2. Dapat dilihat

    pada Gambar 4.2 jaringan dual stack IPv4.

    2. Dual stack IPv6, dimana pada perangkat PC2 dan PC4 akan diganti

    dengan host virtualbox, yaitu Komputer 1 dan Komputer 2. Dapat dilihat

    pada Gambar 4.3 jaringan dual stack IPv6.

    Proses pengujian data dari kedua skenario tersebut dengan cara menjalankan

    program ping dari perangkat host virtualbox yaitu Komputer 1 dan Komputer 2,

    kemudian akan dilihat informasi mengenai perpindahan paket data menggunakan

    program wireshark. Program ping bekerja dengan mengirimkan paket data yang

    disebut sebagai ICMP (Internet Control Message Protocol) echo request dan

    menunggu hingga paket data ICMP echo replay diterima. Pada protokol IPv6

    akan menggunakan paket data ICMPv6 untuk pengujian. Proses ini dilakukan

    untuk mengetahui apakah suatu perangkat jaringan telah terkoneksi dengan

    perangkat lain yang dituju.

  • 32

    Gambar 4.2. Jaringan Dual Stack IPv4

    Gambar 4.3. Jaringan Dual Stack IPv6

    A. Hasil Uji Koneksi

    Hasil pengujian menggunakan perintah ping seperti pada Tabel 4.1 dan

    Tabel 4.2 untuk pengujian dengan protokol IPv4, sedangkan pada Tabel

    4.3 dan 4.4 untuk pengujian dengan protokol IPv6. Pengujian koneksi

    yang dilakukan dengan program ping adalah dengan maksud untuk

    melihat koneksi antar perangkat yang terhubung pada jaringan dual stack.

    Tabel 4.1. Hasil ping Komputer 1 Menuju Komputer 2

    Komputer 1 IPv4

    Paket Waktu 1 (ms) Waktu 2 (ms) Waktu 3 (ms)

    1 41 42 42

    2 40 36 36

  • 33

    3 25 26 26

    4 25 38 38

    Median 32 35 33

    Tabel 4.2. Hasil ping Komputer 2 Menuju Komputer 1

    Komputer 2 IPv4

    Paket Waktu 1 (ms) Waktu 2 (ms) Waktu 3 (ms)

    1 58 42 42

    2 35 36 36

    3 34 26 26

    4 44 38 38

    Median 42 36 32

    Tabel 4.3. Hasil ping Komputer 1 Menuju Komputer 2

    Komputer 1 IPv6

    Paket Waktu 1 (ms) Waktu 2 (ms) Waktu 3 (ms)

    1 41 40 40

    2 37 41 35

    3 35 33 41

    4 35 38 31

    Median 37 38 36

    Tabel 4.4. Hasil ping Komputer 2 Menuju Komputer 1

    Komputer 2 IPv6

    Paket Waktu 1 (ms) Waktu 2 (ms) Waktu 3 (ms)

    1 309 33 33

    2 42 42 39

    3 46 41 40

    4 31 32 39

    Median 107 37 37

  • 34

    Dari tiga kali pengujian didapat jeda waktu pengiriman paket data ICMP

    sebesar 50 byte dengan protokol IPv4 adalah selama 33,3 ms dan jeda

    waktu pengiriman paket data ICMPv6 sebesar 50 byte dengan protokol

    IPv6 adalah selama 37 ms. Hasil pengujian menggunakan perintah ping

    seperti pada Tabel 4.1 dan Tabel 4.2 untuk pengujian dengan protokol

    IPv4, sedangkan pada Tabel 4.3 dan 4.4 untuk pengujian dengan protokol

    IPv6. Pada Gambar 4.4 dan Gambar 4.5 menunjukkan hasil ping dengan

    protokol IPv4, sedangkan pada Gambar 4.6 dan 4.7 menunjukkan hasil

    ping dengan protokol IPv6.

    B. Informasi Paket Data

    Pada Gambar 4.8 dan Gambar 4.9 memperlihatkan informasi dari

    paket data ICMP, sedangkan pada Gambar 4.10 dan Gambar 4.11

    memperlihatkan informasi dari paket data ICMPv6. Pengambilan

    informasi paket data menggunakan program wireshark.

    Terlihat bahwa paket data IPv4 memiliki format yang berbeda dengan

    format IPv6. Pada Gambar 4.8 dan Gambar 4.9 menunjukkan informasi

    paket data ICMP sebesar 92 byte, sedangkan pada proses ping yang

    dilakukan, penulis mengirimkan ukuran file ICMP sebesar 50 byte.

    Keterangan dari paket data dengan protokol IPv4 sebagai berikut.

    1. Paket data ethernet II berisi data mengenai alamat tujuan dan

    alamat sumber. Paket data ini berukuran 14 byte, dengan masing

    masing paket sebesar 6 byte.

    2. Paket data IPv4 memuat berbagai bagian, seperti halnya version,

    header length, protocol, dan lain sebagainya. Pada paket data ini

    berukuran 20 byte.

    3. Paket data ICMP berukuran 58 byte. 8 byte memuat informasi

    mengenai protokol ICMP, yaitu type, code, checksum, dan lain

    sebagainya, serta adanya tambahan data yang berukuran 50 byte.

    Data ini merupakan ukuran file yang ditambahkan pada saat

    program ping akan dijalankan.

  • 35

    Dengan penjabaran tersebut, maka total ukuran file yang dikirimkan tidak

    hanya 50 byte saja, namun adanya tambahan berbagai protokol sehingga

    data dapat diterima ke perangkat tujuan.

    Gambar 4.4. Hasil ping Komputer 1 Jaringan Dual Stack IPv4

  • 36

    Gambar 4.5. Hasil ping Komputer 2 Jaringan Dual Stack IPv4

  • 37

    Gambar 4.6. Hasil ping Komputer 1 Jaringan Dual Stack IPv6

  • 38

    Gambar 4.7. Hasil ping Komputer 2 Jaringan Dual Stack IPv6

  • 39

    Gambar 4.8. Informasi Paket Data ICMP dari Komputer 1 Menuju

    Komputer 2

  • 40

    Gambar 4.9. Informasi Paket Data ICMP dari Komputer 1 Menuju

    Komputer 2

  • 41

    Pada Gambar 4.10 dan Gambar 4.11 menunjukkan informasi paket data

    sebesar 1